03 600 Twin

The Way Out!

Moderator: hemingray

User avatar
TEX
Just realized teal ATV clothes are lame
Posts: 23
Joined: Tue Nov 20, 2007 3:07 pm
Location: Taylor TX

03 600 Twin

Postby TEX » Tue Nov 20, 2007 8:04 pm

So my 03 600 Twin has this herky jerky when you first start out from a stop. all the drive shafts are good and u joints tight. i guess its in the trans or something. this ATV stuff is new to me so im here to learn. figure someone on here will know.
2006 Polaris Sportsman 500 EFI LE-Sunset Red- 26"MudLites-Warn 2.5CI
2003 Polaris Sportsman 600 Twin-Blue
2006 Dodge 2500 4X4 Cummins Diesel

User avatar
Kendo
Is Totally Obsessed
Posts: 939
Joined: Wed Apr 18, 2007 9:26 am
Location: Rocklin, CA

Postby Kendo » Wed Nov 21, 2007 7:20 am

My initial thought would be the belt slipping. How many miles on the current belt?

Welcome!
'15 Can Am Maverick XRS DPS

User avatar
TEX
Just realized teal ATV clothes are lame
Posts: 23
Joined: Tue Nov 20, 2007 3:07 pm
Location: Taylor TX

Postby TEX » Wed Nov 21, 2007 7:41 am

less than 1000- about 980 with 100 hrs
2006 Polaris Sportsman 500 EFI LE-Sunset Red- 26"MudLites-Warn 2.5CI
2003 Polaris Sportsman 600 Twin-Blue
2006 Dodge 2500 4X4 Cummins Diesel

User avatar
Kendo
Is Totally Obsessed
Posts: 939
Joined: Wed Apr 18, 2007 9:26 am
Location: Rocklin, CA

Postby Kendo » Wed Nov 21, 2007 11:18 am

Depending on how the previous owner rode it, that could very well be an issue. Wouldn't hurt to pull the cover and measure it, take a look at what's going on in there.

Belts aren't that much, maybe $30 on eBay.
'15 Can Am Maverick XRS DPS

User avatar
TEX
Just realized teal ATV clothes are lame
Posts: 23
Joined: Tue Nov 20, 2007 3:07 pm
Location: Taylor TX

Postby TEX » Wed Nov 21, 2007 1:52 pm

thanks for the info
2006 Polaris Sportsman 500 EFI LE-Sunset Red- 26"MudLites-Warn 2.5CI
2003 Polaris Sportsman 600 Twin-Blue
2006 Dodge 2500 4X4 Cummins Diesel


Who is online

Users browsing this forum: No registered users and 9 guests